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License for Use of ECH2O DataTrac Software

IMPORTANT NOTICE! Read Carefully Before 
Installation and Use! 

ECH2O DataTrac Software is owned by Decagon Devices, Incorpo-
rated. ECH2O DataTrac is not free Software. You are required to
purchase a license for each computer where ECH2O DataTrac is in-
stalled. By using this software you agree to the following terms and con-
ditions. If you do not agree to the terms of this License, do not use this
Software. 

1. Grant of License. Decagon grants you, the user, a nonexclusive license to use
this Software solely for use with Decagon instruments. This software is not
sold to you.  The user may not reproduce, distribute, sublicense, resell, or oth-
erwise transfer for any consideration, or reproduce for any purposes, the Soft-
ware or any modification or derivation thereof, either alone or in conjunction
with any other product or program. Further, the user may not modify this Soft-
ware. This license replaces and supersedes all previous licenses provided by
Decagon.

2. Disclaimer of Warranties. THIS SOFTWARE IS PROVIDED TO THE
USER "AS IS."  DECAGON MAKES NO WARRANTIES, EITHER EX-
PRESS OR IMPLIED, WITH RESPECT TO THIS SOFTWARE AND/OR
ASSOCIATED PRODUCTS AND/OR MATERIALS PROVIDED TO
THE USER, INCLUDING BUT NOT LIMITED TO ANY WARRANTY
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE
OR AGAINST INFRINGEMENT. DECAGON DOES NOT WARRANT
THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL
MEET YOUR REQUIREMENTS, OR THAT THE OPERATION OF
THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE, OR
THAT DEFECTS IN THE SOFTWARE WILL BE CORRECTED. FUR-
THERMORE, DECAGON DOES NOT WARRANT OR MAKE ANY
REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF
THE USE OF THE SOFTWARE OR ANY DOCUMENTATION        PRO-
VIDED HEREWITH IN TERMS OF THEIR CORRECTNESS, ACCURA-
CY, RELIABILITY, OR OTHERWISE. NO ORAL OR WRITTEN
INFORMATION OR ADVICE GIVEN BY DECAGON OR A
DECAGON AUTHORIZED REPRESENTATIVE SHALL CREATE A
WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WAR-
RANTY.

3. Limitation of Liability. BY USING THIS SOFTWARE YOU AGREE
THAT DECAGON IS NOT LIABLE FOR ANY CLAIMS OR DAMAGES
WHATSOEVER, INCLUDING PROPERTY DAMAGE, PERSONAL IN-
JURY, INTELLECTUAL PROPERTY INFRINGEMENT, LOSS OF
PROFITS, OR INTERRUPTION OF BUSINESS, OR FOR ANY
SPECIAL, CONSEQUENTIAL OR INCIDENTAL DAMAGES, HOW-



EVER CAUSED, WHETHER ARISING OUT OF BREACH OF WAR-
RANTY, CONTRACT, TORT (INCLUDING NEGLIGENCE), STRICT
LIABILITY, OR OTHERWISE.

4. Construction. If any provision of this License is inconsistent with, or cannot
be fully enforced under, the law, such provision shall be construed as limited to
the minimum extent necessary to be consistent with and fully enforceable un-
der the law. If for any reason a court of competent jurisdiction finds any pro-
vision, or portion thereof, to be unenforceable, the remainder of this License
shall continue in full force and effect. 

5. Applicable Law. This License shall be deemed to have been made in, and
shall be construed pursuant to, the laws of the State of Washington. The United
Nations Convention on Contracts for the International Sale of Goods is spe-
cifically disclaimed.

6. Title. All title and copyrights in and to the Software the accompanying print-
ed materials, and any copies of the Software, are owned by Decagon Devices
Incorporated. This Software is protected by copyright laws and international
treaty provisions.

7. Termination. This License will automatically terminate if Customer fails to
comply with any of the terms and conditions hereof. In such event, Customer
must destroy all copies of the Software and all of its component parts.

8. Complete Agreement; Governing Language. This License constitutes the
entire agreement between the parties with respect to the use of the Decagon
Software licensed hereunder and supersedes all prior or contemporaneous un-
derstandings regarding such subject matter. No amendment to or modification
of this License will be binding unless in writing and signed by Decagon. Any
translation of this License is done for local requirements and in the event of a
dispute between the English and any non-English versions, the English version
of this License shall govern. 

9. Enforcement. The provisions of this Agreement shall be enforceable regard-
less of any other claim or dispute existing between the parties, and in any action
for violation of the terms of this license, the prevailing party shall be entitled
to recover costs and attorney’s fees. Jurisdiction and Venue shall be in Whitman
County, Washington.   

ECH2O, ECH2O DataTrac, Em50, Em50R, Em5, and Em5R are registered
trademarks of Decagon Devices, Inc. Em5b, EchoLink and DataStation are
trademarks of Decagon Devices, Inc.

Copyright ©2007-2009 Decagon Devices, Inc. All
rights reserved.
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1. Introduction
Thank you for purchasing ECH2O DataTrac. DataTrac
allows you to collect, manipulate and analyze data from
the Em50, Em50R, Em5, Em5R, and Em5b loggers.
DataTrac will also work with the DataStation, which acts
as a data collection point for multiple loggers. 

This program has been designed for ease of use and incor-
porates many features to make your job easier. This man-
ual is designed to help you understand and fully utilize
DataTrac to accomplish your research goals efficiently. 

System Requirements
To use ECH2O DataTrac, you must have the following
minimum computer resources:

•  CD-ROM drive
•  64 MB of RAM for Windows 98
•  128 MB of RAM for Windows NT (SP5)/2000/ 

      XP/Vista
•  100 MB free hard drive space
•  Monitor set to 1024x768 or higher resolution
•  A Windows-compatible printer for report printing
•  Serial port or serial-to-USB adapter

Customer Support
If you ever need assistance with your ECH2O DataTrac,
or if you just have questions, there are several ways to con-
tact us:
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E-mail
support@decagon.com
Please include your name, contact information, instru-
ment serial number(s), and a description of your problem
or question.

sales@decagon.com
Please include your name, address, phone number, the
items you wish to order and a purchase order number.
Credit card numbers should always be called in.

Phone
1-800-755-2751 (USA and Canada Only)
1-509-332-2756 (International)

You can also send feedback to Decagon using the “Send 
Feedback to Decagon” feature. See Appendix A for more 
information.

Warranty Information
ECH2O DataTrac has a 30-day satisfaction guarantee. 
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2. Installing DataTrac

Installing DataTrac from CD
DataTrac is a Windows application that installs from the
CD found in the front cover of the DataTrac user’s man-
ual. Place the CD in your computer’s CD drive, wait for
the “ECH2O Software Installer” to appear, and select
“Install ECH2O DataTrac” from the menu. If the installer
does not launch by itself, go to My Computer, select your
CD drive, and double-click on the “autorun.exe” file.
Then follow the subsequent installation prompts. 

Installing DataTrac from the Web
Updates for the DataTrac software can be found online at
www.decagon.com/support/downloads. If your computer
is connected to the Internet, you can use the Decagon
Version Check web engine to check for updates to
DataTrac. Select “Check for Updates...” from the Help
Menu. 

You can find out which version is currently installed on
your computer by clicking on the Help Menu and selecting
“About DataTrac”.

Licensing DataTrac
The copy of DataTrac you install from the CD is a 30-
day evaluation copy! After installation, you will have 30
days to license your copy of DataTrac. Licensing DataTrac
allows you to use all of the program’s indefinately. After
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30 days, you will be unable to use the  program if it
has not been licensed!

To license your copy of DataTrac, you will need your Soft-
ware License certificate, which you receive after purchas-
ing the full   version of DataTrac. Do the following:
1. Go to Help > License. This opens the License Wizard.

The first page will display the license status of your
copy of DataTrac as NOT licensed, and the number
of days remaining until your evaluation period expires. 

2. Click “License”. This displays the license agreement,
and asks you to accept or decline. If you choose
“Decline” you cannot continue, and will only be able
to click “Cancel” and start over. 

3. Select “Accept License Agreement” if you agree. This
activates the “Next” button. Click it to move to the
Licensing Information screen. 

Enter your full name, company name, and your license
code exactly as written on the license certificate. Please
contact Decagon if the information on your license
certificate is incorrect.
NOTE: Once you have licensed DataTrac, returning to the License
screen will display the “Remove License” button. This button will
remove DataTrac's license and you will need to re-license the program
to continue using it. This was intended to let the user move their
license to a new computer. 
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3. DataTrac Introduction
DataTrac will create a directory in the Start Menu when it
has finished installing. Go to Start > Programs > ECH2O
DataTrac, and click the DataTrac icon to launch the pro-
gram. When it opens, you will see an empty screen similar
to the one shown below. The screen is divided into six
main sections. Each of these sections is explained in detail
below. 

NOTE: The term “logger” can refer to any of the ECH2O system
loggers (Em50, Em5b, etc.). The term “devices” refers to the Dat-
aStation and loggers.

device status area menu bar toolbar

TaskbarDevice Directory Device Description Area
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The Menu Bar
DataTrac is a Windows-based program, and features a
central menu bar. The menu bar allows you to perform
operations and access program features. DataTrac’s menu
bar contains six menus, each one containing several sub-
menu items. A brief overview of each menu and    sub-
menu follows.

File
The File Menu allows you to save and open data files, and
print saved data.

• Import Data File... Imports measurement data
from a DataTrac data file (see Chapter 6 for infor-
mation on reading in saved data files).

• Re-Import Data File... DataTrac normally ignores
duplicate data when downloading or importing data
into DataTrac. Using this feature allows you to
replace data already in your DataTrac database.
DataTrac compares the date and time for each data
point. If the data point is already in the database, the
new data point replaces the old. If the new data
point doesn’t exist in the database, then it is added.
Warning, re-importing data will overwrite any
data points you may have manually edited. Any
data points marked “IGNORED” will be visible
on the chart.

• Export. Exports data and logger settings as a bun-
dled data file for future use.
- Table... When in Table View, you can export the
table into several different formats, which can be
viewed with most standard spreadsheet or word pro-
cessing programs.
- Chart... When in Chart View, you can export the
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chart as a picture file to use with most word process-
ing and web editing programs. 
- Transfer Set... Exports a data file called a transfer set,
which contains all of the data, configuration settings,
and tree information for a selected logger.

• Print Setup... Configure printer settings and options
for printing reports. NOTE: When you configure your
printer, the paper orientation is ignored; DataTrac will only
print portrait-style reports.

• Print Report. A report contains information about
the logger, the chart data (as seen on the screen), the
report summary data, and any recommendation text
(see Chapter 4 for more information).

• Exit. Closes the program. 

Edit
The Edit Menu allows you to copy, and select on-screen
data.

• Undo. Disabled.
• Cut. Disabled.
• Copy (Table View only). Allows you to copy data

cells or rows and copy them into word processing or
spreadsheet programs such as Word or Excel.

• Copy Chart (Chart View only). Copies the visible
chart and converts it into a picture file for pasting
into other applications. You can select what picture
format to use in the DataTrac Preferences menu.
(See Chapter 5 for more details.)

• Paste (Table View only).
• Select Visible Data Rows (Table View only).

Selects all the data rows currently visible on the
screen.
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• Select All. Selects all the cells in Table View, or the
cells in Chart View.

View
The View Menu allows you to control how data is viewed
in DataTrac.

• Chart View. Check mark to the left indicates that
the Chart View is currently active.

• Table View. Check mark to the left indicates that
the Table View is currently active. 

• Enable Editing (Table View only). Allows you to
edit the values in the table. 

• Show Unprocessed Data (Table View only). Shows
the data as it comes in from the logger, raw and
unprocessed.

• Reload Data For (device name). The Reload Data
option is useful if you are not seeing the data dis-
played as you expected in the Chart. This option will
reload the data from the selected logger.

• Zoom In. (Chart View only) Increases the chart size.
• Zoom Out. (Chart View only) Decreases the chart

size.

Setup
The Setup menu allows you to create Farms and Fields,
configure devices, and modify program settings in the
DataTrac Preferences.

• Create New. Create a new Farm, Field, Em50,
Em5b, or DataStation.

- Em50... Create a new Em50 in the device directory.
- Em5b... Create a new Em5b in the device directory.
- DataStation... Create a new DataStation.
- Farm. Create a new Farm in the device directory.
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- Field. Create a new Field level of a Farm.
• Configure (device/Farm/Field name). Takes you

to the Configuration dialog, used for configuring
devices, Farms, or Fields within DataTrac.

• Rename (device/Farm/Field name). Change a
selected device’s, Farm’s, or Field’s current name.

• Redeploy (logger name). Allows you to restart a
logger as if it were a new logger with no data (see
Chapter 3 for more information).

• Delete (device/Farm/Field name). Deletes the
selected device, Farm, or Field from the system.

• DataTrac Preferences. Opens the Preferences dia-
log which modifies program operational settings. See
Chapter 5 for information on the Preferences Menu.

Actions
The Action menu is used for connecting to your logger,
and downloading data from it. 

• Connect. Connects to a selected logger through the
COM port selected in the Connect Via combo box.

• Connection Query (applies to radio loggers only).
Use to connect to any radio logger on a specified
channel/sub-channel.

• Download. Downloads data from a device. Not
enabled unless you are connected.

- New Data. Downloads data that has been collected
by the device since the last download from that device. 
- All Data. Downloads all the data currently stored in
the device’s data memory.
• Scan Ports. Takes real-time readings of all a logger’s

ports. You must be connected to a logger to enable
this option. 
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• Device Tools. Contains several tools for interfacing
with your device. 

- Set Time. Sets the logger’s time to the computer’s
system time.
- Firmware Test. Tests the integrity of the device’s   
firmware. DataTrac reports as either Good or Bad.
- Telemetry Test. Allows you to verify the radio con-
nection between the radio logger and the DataStation.
Choose "Telemetry Test" from the Actions Menu.

Click the Test button and the test will begin. When the
test has finished you will be presented with the results
of the test. You may have to relocate the radio logger
while doing the Telemetry Test in order to find the
best connection quality. Once you have found the
radio logger location that provides the best connec-
tion quality, install the radio logger at that location.
Disconnect from the radio logger.

NOTE: Telemetry Test only works with Em50 loggers run-
ning firmware 1.12 or newer.
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- Erase Data in (name of device). Erases all of the
data currently stored in the device.
 WARNING! the data cannot be recovered once
erased!
- Initialize Radio. Resets a device’s radio.
-Initialize (device name). Resets the selected device. 
WARNING! This will erase all data currently 
stored in that device’s data memory, and cannot
be undone!

Help
The Help menu contains the DataTrac help file, licensing
wizard, and program version.

• DataTrac Help. Opens the DataTrac help file,
which contains help topics for each aspect of
DataTrac and some problem solutions.

• Send Feedback to Decagon. This menu item helps
you send product feedback, bug reports, or feature
requests to Decagon. Your computer must be con-
nected to the internet for this feature to work. See
Appendix B for more information. 

• Check for Updates. Connects to the Internet to
find any available program updates (must be con-
nected to the Internet for this option to work).

• License. Opens the License wizard to license
DataTrac. DataTrac comes with a 30-day evaluation
period, but you cannot use the program indefinitely
until you purchase and enter a program license key.

• About DataTrac. Displays program version.
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The Device Status Area
The device status area displays
information about the device cur-
rently selected in the device
directory, and connected to

DataTrac. For loggers, when connected it will display the
logger’s type, given name, logger date and time, and bat-
tery status.

When DataTrac is connected to a
radio logger via the Rm1, the
device status area also shows the
radio signal strength information

(RSSI) for the connection.

Using the Toolbar
Across the top of the screen are several tools used to
interface with your logger, as shown in the picture below.
These controls make up the toolbar.

A: Connect Via. Select a COM port to connect to a 
logger via a RS-232 serial cable (direct connect) 
or a Rm1 radio modem.

B: Connect/Disconnect button. Connects to or 
disconnects from a device. 

A B EDC F G H
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C: Download.  Downloads data that has been             
collected by the device since the last download from 
that device. 

D. Scan.  Allows you to make instantaneous 
readings of all a logger’s ports when you are  
connected to that logger.

E: Report. Allows you to print or create a PDF
document of the currently selected logger in the
Device Directory that includes logger location, name,
notes, current chart view and summary data below the
chart.

F: Chart/Table View.  Switches between Chart and
Table views of downloaded data.

G: Configure.  Takes you to the Configure menu.

H: Soil Moisture. Here you can choose how soil
moisture data will be displayed: 1) in terms of Water
Content, 2) Plant Available Water, or 3) Inches per
Foot.

The Device Directory
The device directory is where all devices
will appear. DataTrac uses Farms and
Fields to organize devices. DataTrac
refers to each main location as a Farm.
Within each Farm can be placed sub-
locations, known as Fields.
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Device Description Area
The device description area displays information about
any   highlighted node on the tree that is not a logger. For
loggers, this will display measurement data as a graphical
chart or in a table.  

Taskbar
The taskbar displays DataTrac system messages.
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4. Common Tasks
This chapter details the most common tasks users would
like to accomplish. Other features of the program and
tasks not discussed here are described later in this manual.     

Setting Up the Device Directory
Once DataTrac has been installed and licensed, you are
ready to begin setting up the device directory.

Creating a Farm
To create a new Farm:
1. Select Setup > Create New > Farm. The dialog box

below will appear. 

2. Enter a name for the farm (up to 24 characters) and
click “OK”. The “Farm Level Setup” dialog, shown
below, will appear next:
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• In the Farm Level Name field, you can enter a new
name for the Farm or modify the current name.

• Enter the Farm’s acreage in the Total Acres field.
• Use the Notes fields to enter any comments about

that farm (i.e. crop type).

3. Fill in the appropriate fields, then click “OK”. The
Farm will appear in the device directory, and its name,
acreage, and any notes will appear in the device
description area. The screen will look similar to the
one shown below.
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You may add additional Farms by repeating these steps.

Creating a Field
To add a Field to an exiting Farm:
1. Select Setup > Create New > Field. The dialog box

below will appear:      
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2. From the “Farm” drop-down list, select which
existing Farm the Field will be associated with.

3. Enter a name for the Field (up to 24 characters) and
click “OK”. The “Field Level Setup” dialog, shown
below, will appear next:      

• In the Field Level Name field, you can enter a new
name for the Field, or modify the current name.

• Enter the Field’s acreage in the Total Acres field.
• Enter the crop name in the Crop Name field.
• Use the Notes fields to enter any comments about

that field (i.e. location, special conditions, etc.).

4. Fill in the appropriate fields, then click “OK”. The
Field will appear in the device directory, and its name,
acreage, crop name, and any notes will appear in the
device description area. The field’s name will also
appear in the device status area. The screen will look
similar to the one shown below.



 ECH2O DataTrac User’s Manual
4. Common Tasks

19

You may add additional Fields by repeating these steps.

You can delete Farms and Fields by selecting them in the 
device directory, then selecting Setup > Delete (name of 
Farm/Field). 

WARNING! When deleting a Farm or Field, all log-
gers in that Farm or Field will be deleted!

Connecting to and Configuring a
DataStation
DataStations are different from loggers in that the
DataStation receives data from multiple radio-enabled
Em50R loggers. The logger data from the DataStation still
requires configuration and entry into the device directory,
but this is handled differently than connecting to an indi-
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vidual logger. The DataStation needs to have the parame-
ters Name, Radio Channel, and Radio Sub Channel set
before it can collect data from loggers. The following
section details how to connect to and configure DataSta-
tions in DataTrac.

Connecting to a DataStation
1. Connect the DataStation to the computer’s communi-

cations port via an RS232 cable. 
2. In DataTrac, select the appropriate COM port from

the “Connect Via” drop-down list, and click the “Con-
nect” button on the toolbar. 

3. After establishing connection with the DataStation,
the DataStation will be added under the Data Source
node in the device directory area.

4. The following information will be displayed in the
device description area: Serial Number, Firmware Ver-
sion Number, Radio Channel, Radio Sub Channel,
Last Time Connected, and Last Downloaded Data. 

Device Setup
The DataStation can now be configured. There are three
ways to get to the Device Setup screen: 1) click on the
menu Setup > Configure DataStation Name, 2) click on
the Configure toolbar button, or 3) double click the left
mouse button on the DataStation node in the device
directory. The Device Setup screen contains one sub-
screen or tab labeled “DataStation”. 
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DataStation Tab

DataStation Tab in Device Setup

This screen features three main sections:

1. Identity. This section displays the basic information
about the DataStation.

- Change Name: Click the “Change Name” button if 
you wish to rename your current logger.
- Erase Data: It is recommended that you erase the log-
ger’s memory before making measurements to ensure 
a clean data set. Click “Erase Data” to erase all data 
stored on the logger. 
- Note: In the “Note” field, you can write more detailed 
information about the logger; for example, the type of 
plant growing at that site, the name of the location, 
etc. Anything you type here appears on printed data 
reports.
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2. Location. In this section you can set the physical
location of the DataStation (latitude and longitude).

3. Radio. Use this section to change the following:
- Channel: Can be set from 0 to 6 
- Sub Channel: Can be set from 0 to 65534
- Firmware: (Read-only, cannot be modified) Displays
the radio module’s firmware   version.

Connecting/Configuring a Logger
Before a logger can be used with DataTrac, it will need to
be configured and entered into the device directory.
Loggers need to have parameters such as name, date, time,
measurement interval, and communication mode set. The
radio-enabled logger will not respond to radio contact
until properly configured. The following section details
how to connect to loggers.

Connecting
Before you can configure a logger, you must first physi-
cally connect it to your computer. Two methods can be
used to accomplish this.  A USB to stereo cable adapter
(UCA) was included with with your logger.  Also, if you
prefer a serial to stereo adapter (SCA)  these are also avail-
able upon request.

Note: you must install the USB driver before connecting the USB
cable to your computer.  You can download the Microsoft Windows
Drivers at www.decagon.com/downloads.  
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1. Connect you cable adapter UCA or SCA to a Commu-
nications port on your computer and the stereo plug
end to the logger’s Communications Port (COMM
PORT for the Em50/Em50R, Port 1 for the Em5/
Em5R, and Em5b).

2. Select the appropriate COM port in the “Connect 
Via” drop-down list, then Click the “Connect” button.

3. Once connected you will see the logger’s name appear
in the device directory under the New Devices farm.
The logger’s type, name, logger time, and battery sta-
tus will appear in the device status area. DataTrac will
also indicate that your logger has not yet been config-
ured. The screen will look similar to the one shown
below. 

chart area

chart period

summary area
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• The chart area is where charted data will appear.
• The chart period allows you to set a date range for

charted data. You can select what time interval of
data is displayed (Day, Week, Two Weeks, 30 Days,
Season, All Data, or Custom). 

• The summary area displays a summary of each
chart data line, showing each line’s Average, Mini-
mum, Maximum, Total, and Events values. 

Connect via an Rm1 radio modem:
1. Connect the Rm1 to your computer with an RS232 

serial cable.
2. In DataTrac, select which COM port the Rm1 is con-

nected to from the “Connect Via” combo box, and 
select “Connect Via Rm1 on...”. 

NOTE: You cannot connect to the Rm1 itself, only connect 
through it to radio loggers.

3. Click the “Connect” button on the Toolbar. 
• If you have not already highlighted a logger in the

device directory, DataTrac will ask you which chan-
nel and sub channel you would like to use:
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Enter a value for each, then click “OK”. 

• If you know which logger you want to connect to,
select it and then click “Connect”. DataTrac will not
display the “Rm1 Settings Dialog”, because these
values are already set. 

NOTE: If you try to connect to a non-radio enabled logger,
DataTrac will display the following error message:

This means that:
- The device is not a radio logger (Em50R or Em5R);
- The device’s radio is either not connected or not cor-
rectly configured (i.e. its radio mode is set to “Radio
Off/No Radio”).
Make sure you are using a radio logger and that it is
correctly configured, then connect again.

4. If the connection is successful, the radio logger’s
information and RSSI data are displayed in the device
status area. DataTrac will also indicate that your logger
has not been configured yet. 
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Once you have connected to your logger, click the
“Configure” icon on the Toolbar to continue. This will
open the Device Setup screen. 

Device Setup
The Device Setup screen contains four sub-screens or
tabs, which can be navigated by clicking the tabs at the top
of the screen. The first is the Logger tab. 
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Logger Tab

This screen features two main sections:

1. Identity. This section gives you the basic information
about your logger.
Change Name - Click the “Change Name” button if you
wish to rename your current logger
Set Time - Click “Set Time” to set the logger time to
the system time on your computer
Erase Data - It is recommended that you erase the log-
ger’s memory before making measurements to ensure
a clean data set. Click “Erase Data” to erase all data
stored on the logger. 
In the “Note” field, you can write more detailed infor-
mation about the logger, for example, the type of plant
growing at that site, the name of the location, etc.
Anything you type here appears on printed data
reports.
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2. Location. In this section, select the Farm and Field
where you want this particular logger to be grouped
within the device directory. At the bottom of the
screen you can set the physical location of the logger
(latitude and longitude).

Configuration Tab

Selecting the Configuration Tab displays the screen below:

This page is where you set up the sensor type, measure-
ment interval, and charting preferences for your logger.
This screen is divided into four sections:

1. Template and Measurement Interval
- Apply Configuration Template. If the user wants the data
to always be displayed in the same way for more than
one logger, then the user can create a configuration
template. This is done by selecting the desired values
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for Depth (Inches), Legend Name, Trace Color, Trace
Size, and Data marker. Click on the Apply Configura-
tion Template drop down list, select Save Current
Configuration as…, type in a name that is descriptive
of the configuration and click OK. The Configuration
Template is now saved in the Apply Configuration
Template list and can be applied to any logger in the
Device Tree. More Configuration Templates can be
created as needed and when Configuration Templates
are no longer needed, they can be deleted. An existing
Configuration Template can be modified by applying
the template to a logger, deleting the original Configu-
ration Template, making needed changes to the cur-
rent logger, and saving the configuration back to the
original Configuration Template name.

- Measurement Interval. Loggers allow you to select a
measurement interval between 0 and 1440 minutes. A
measurement interval of zero (0) stops the logger from
making measurements.

2. Sensors.
- Sensor Types. In the Sensor Type combo boxes you
can use the drop-down menus for each port to “tell”
the logger what type of sensor is plugged into each of
the 5 ports. However, if you try to configure the ports
without first setting up the logger in the “Logger” tab,
the sensor selection will be limited. Therefore, you
must make sure that you have configured the logger in
the “Logger” tab before you can configure the sen-
sors. Once this is done, click “Apply” and all of the
sensors will become available.
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- Depth (Inches): Use the Depth edit boxes to note the
depth in inches that the sensors are placed in the soil.

3. Chart. This section will be discussed in the “Viewing 
Data” section.

4. Radio.  In the “Radio” section, you set the radio
mode, channel and sub channel for Em50R radio log-
gers.  There are two Distinct types of modes to choose
from,  Transmit and Two-way. Transmit modes are for
use with a DataStation.  There is no limit to the num-
ber of loggers transmitting to a DataStation.  Two-way
modes are for use with an RM1 connected to a PC.  

• Radio Off/No Radio: The radio logger will take and
store measurements as configured, but will only
download via a direct connection using a serial cable
adapter (SCA) or USB cable(UCA) and a computer.

• Confirmed Delivery Transmit: This is the most
robust transmit radio mode. The radio logger adds a
checksum to the data packet before broadcasting the
data to a datastation. The logger then waits for the
DataStation to confirm it correctly received the data
packet. If the logger doesn’t hear the confirmation, it
retries sending the packet again. The logger stops
trying to transmit to a DataStation after 25 attempts.

• Transmit Only: In this mode, every time the radio
logger stores a measurement (according to the pro-
grammed measurement interval), it will also transmit
the measurement to a “listening” receiver. Choose
this mode when using a DataStation to receive your
data. This radio mode uses the least battery power.
The actual transmit time is randomly delayed to help
prevent two or more radio loggers from transmitting
at the same time.
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• Two-way 6:00-18:00: This option is for use with an
Rm1 radio modem connected to a PC. In this mode,
from 6:00 to 18:00 (6 am - 6 pm), the radio logger
will “listen” for any available connection with an
Rm1 every 45 seconds. If an Rm1 is actively trans-
mitting, the radio logger will wait for a login com-
mand for a short time. This mode is useful for
reducing battery consumption by not trying to make
radio connections during the night.

• Two-way 24-hour: The radio logger will function as
described above on a 24-hour basis with an RM1. 

• Transmit + Two-way: Communicates as described
above, but will also transmit data as measurements
are taken. This mode uses the most battery power,
and is primarily for troubleshooting radio connec-
tion problems.

• CD Transmit + Two-way: This mode combines the
Two-way Radio mode and the Confirmed Delivery
Transmit Radio mode. You could use this mode
while configuring and testing your radio network.
You should not leave your radio logger in this mode
because it uses the most battery power of all the
radio modes. Using CD Transmit + Two-way radio
mode with the wake interval set to 1 or 2 will cause
the batteries of your logger to drain very rapidly.

NOTE: Em50R loggers must have firmware version 1.12 or later
to enable the Confirmed Delivery Transmit mode and Telemetry Test
feature. Your DataStation must have firmware version 1.09 or later
to receive Confirmed Delivery Transmit mode data packets. Contact
Decagon for an application note that covers the steps needed to
upgrade your hardware.
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• Unknown Radio Mode: When DataTrac connects to
a radio logger and cannot identify the radio mode, it
will be automatically set to unknown. 

- Channel: Can be set from 0 to 6. 
- Sub Channel: Can be set from 0 to 65534
- Firmware: (Read-only, cannot be modified) Displays
the radio module’s firmware version. 

Calibration Tab
This tab is discussed in Chapter 5. 

Chart Axis Tab
This tab is discussed in Chapter 5. 
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5. Viewing The Data

Downloading Data
Once your loggers are properly configured and collecting
data, you will eventually want to download the data that
has accumulated into DataTrac. 

To download data:
1. Connect to your device as described in the previous 

chapter.
2. Once connected, click the “Download” icon, or go to 

Actions > Download, and select an option. 
3. A screen indicating a download is in progress will

appear, similar to the one shown below. To cancel the
process at any point, click the “Cancel” button.

4. If the device you are downloading from is a DataSta-
tion, then you will need to configure the loggers (as
described in the “Connecting to and Configuring a
Logger” section) listed in the New Devices section of
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the device directory before you can see the data in the
chart.

5. Once the new data is read in, the data will appear in
the chart when you select that particular logger in the
device directory.

Different Views
After you download data into DataTrac, you can see your
data in two different views. 

Chart View
When you click on the Chart View icon, you will see your
data in terms of a graph chart 
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An axis will appear for each type of measurement being
displayed. Using your mouse pointer, you can click on any
of the x- or y-axes and move them for ease of viewing. To
zoom in, click on the zoom tool in the lower right corner,
or input a specific range of dates in the “Chart Period”
box at the bottom of the graph. You can also select from
Day, Week, Two Weeks, Month, Season, or All Data view
in the “Chart View” drop-down menu for custom views
of the data. 

Understanding the Chart Period
The Season View controls regulate the number of data
records that are loaded from the database into the chart.
This improves the performance of the application.

To cause the data in the range defined in the Season View
settings to be loaded into the chart requires the user to
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select one of the Chart Period Choices: Day, Week, Two
Weeks, 30 Days, All Data, or Custom. When you select a
Chart Period option, the records in the database that
match the date range you have selected in Preferences
menu are loaded into the chart. The right hand side of the
chart displays the last data record from the database that
fit the Season View criteria, and the left end displays the
time span listed in the Chart Period control. 

• Day. Zooms the chart to the last day of data loaded
from the database. 

• Week. Zooms the chart to the last week (7 days) of
data loaded from the database. 

• Two Weeks. Zooms the chart to the last two weeks
(14 days) of data loaded from the database.

• 30 Days. Zooms the chart to the last 30 days of data
loaded from the database.

• All Data. Zooms the chart to show all of the data in
the database.

• Custom. Enables the user to select the Start and
Stop dates located to the right of the Chart Period
drop down list. 

NOTE: The time axis range depends on how much data is in the
database. For example, if you set a minimum number of two months
to display, but there is only three days of data loaded into the data-
base, the chart will only display those three days. Data is also
arranged such that the current data point is at the right of the screen.
For example, if you want to view data from June 2005 to June
2006, the chart would display data from just before the first and
slightly after the last data points in that range. However, if you select
Week View, the chart will place the current date’s data point at the
right of the screen and display data from a week before it to the left. 
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By double clicking with the left mouse button on a chart
data point, the table will be loaded and the data point
clicked on will be selected. This makes it very easy to look
at a specific data point in the table view.

A right mouse click on the chart will bring up a menu with
the following choices:

• Adjust Axis Scale. Opens the Chart Axis tab in the
Device Setup screen.

• Table View. Switches to Table view.
• Copy Chart. Copies the chart to the clipboard so

that it can be pasted into other programs for use in
reports or web pages.

Below the graph is a small summary table showing the
Average, Minimum, Maximum, Total, and Events values
for each port.

A right mouse click on the summary table will bring up a
menu with the following choices:

• Copy. Copies the selected cells onto the clipboard.
• Select All. Selects all of the cells in the summary

table.

Table View
The Table View displays your data in a spreadsheet for-
mat, with the date and time of each measurement on the
y-axis and the 5 ports on the x-axis. The Table View dis-
plays your data in a tabular “spreadsheet” format, with the
date and time of each measurement on the y-axis and the 5
ports on the x-axis. Clicking the check box next to a read-
ing will display IGNORED. That reading will then no
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longer appear in the Chart View. You can restore it by
clicking the check box again. 

A right mouse click on the table will bring up a menu with
the following choices:

• Show Unprocessed Data. Displays the data in raw
or unprocessed values.

• Chart View. Switches to Chart view.
• Copy. Copies the selected cells to the clipboard so

that it can be pasted into other programs for use in
reports or web pages.

• Paste. Pastes the value in the clipboard to the
selected cell.

• Select Visible Data Rows. Selects the data rows
that are visible to the user.

• Select All. Selects all data.
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When the table is displaying the data as unprocessed val-
ues the first choice in the right mouse click menu will be
Show Processed Data.

Editing Data Points
The Em50 compatible sensors can be edited in the table 
view in accordance with the following table:

Em50 
Sensor

Processed 
Data

Unprocessed 
Data

EC-20 Yes Yes

EC-10 Yes Yes

EC-5 No Yes

ECH2O-TE No No

LWS No No

ECT Yes Yes

ECRN Yes No

G1 Yes No

PS1 No No

mV Yes Yes

EHT Yes No

EC-TM No No

MPS-1 No No

PYR No No
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If you use a Drain Gauge, a Rain Gauge, or pressure
switch, which employ an accumulator (the total number of
dump events in the system), and you edit a data entry in
the Table View, if the next entry is a non-zero value you
must edit each successive entry until a zero value is
obtained! Unedited events generate an internal error mes-
sage, which prohibits DataTrac from making further cal-
culations until two events with equal accumulators are
supplied. 

Charting Data
To chart data, click on the logger of interest in the device
directory.

• Change display period by choosing a default interval
from the Chart Period combo box. 

• View a specific display period by setting the desired
interval in the Chart Period boxes beneath the chart.

• Remove and restore traces from the graph by click-
ing on the Legend Name of the trace.

• Move the axis by placing the pointer over the axis
numbers and holding down the left mouse button
while you move it.

• View soil moisture in terms of Water Content, Plant
Available Water or Inches Per Foot by choosing

QS0-S No No

5TE No No

10HS Yes Yes

Em50 
Sensor

Processed 
Data

Unprocessed 
Data
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between alternatives in the Soil Moisture combo box
in the upper right corner. 

• Zoom in and out of the graph screen by choosing
the (+) or (-) magnifying tool from the lower right
corner of the window and by clicking on the magni-
fying glass icon.

Adjusting the Chart Axis
DataTrac allows you to adjust the range of the chart axis.
Do the following:
1. This feature can be accessed in three ways:

- Select Setup > Configure (logger name), and click 
the Chart Axis tab;
- Double-click on a logger in the device directory to 
open the Configuration menu, and select the Chart 
Axis tab.
- Click the Configuration button on the toolbar, and 
select the Chart Axis tab, shown below.
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• Select the data view you would like to adjust from
among the alternatives shown in the box in the
upper left corner of the device setup screen.

• Set the desired range by adjusting the Maximum and
Minimum values in the Properties section of the
screen.

• The axis color may also be changed if desired.
• Click the Apply button in the bottom right corner of

the window to apply the settings and remain in the
setup window. Click OK to apply the settings and
exit the setup window.

NOTE: The chart axes were designed to be larger than necessary to
allow the user to drag traces on and off of the screen. For example, if
you have a busy chart and want to move a particular trace to make
more space, click on that trace’s chart axis and drag the mouse
upward to take the trace off the screen. The trace will be returned to
its starting position if you leave the chart view and return to it.

Configuration
You can also use the Device Setup menu to control how
data are displayed in DataTrac. See Chapter 4 for more
information on this menu. 

Configuration Tab

Selecting the Configuration Tab displays the screen below:



 ECH2O DataTrac User’s Manual
5. Viewing The Data

43

This page is where you set up the sensor type, measure-
ment interval, and charting preferences for your logger. 

Apply Configuration Template. If the user wants the
data to always be displayed in the same way for more than
one logger, then the user can create a configuration tem-
plate. 

This is done by selecting the desired values for Depth
(Inches), Legend Name, Trace Color, Trace Size, and Data
marker. Click on the Apply Configuration Template drop
down list, select Save Current Configuration as…, type in
a name that is descriptive of the configuration and click
OK. The Configuration Template is now saved in the
Apply Configuration Template list and can be applied to
any logger in the Device Tree. 
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More Configuration Templates can be created as needed
and when Configuration Templates are no longer needed,
they can be deleted. An existing Configuration Template
can be modified by applying the template to a logger,
deleting the original Configuration Template, making
needed changes to the current logger, and saving the con-
figuration back to the original Configuration Template
name.

Measurement Interval. Loggers allow you to select a
measurement interval between 0 and 1440 minutes. A
measurement interval of zero (0) stops the logger from
making measurements.

The remainder of the screen is divided into three sections:

1. Sensors.  Here, set which type of sensor is connected
to each port, and each sensor’s measurement depth.

2. Chart.  Here, you can modify settings changing how 
the chart data is displayed.
- Legend Name: Chart legend and table column names.
- Trace Color: A color to represent each sensor on 
the graph.
- Trace Size: Trace line and width sizes. 
- Data Marker: Set markers for data points on 
trace lines.

3. Radio. See the radio section in Chapter 4 under Con-
figuration Tab.
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Calibration Tab 

The Calibration tab of the Device Setup allows you to
apply soil-specific calibrations to your ECH2O soil
moisture probes, as well as apply calibration to other sen-
sors that require sensor- specific calibration. 

This screen has three sections:

1. Port List. In the upper left corner of the screen is the
Port List. From this list select sensor ports that have a
sensor connected. The list is organized by port
number and legend name. 

2. Sensor specific calibration information. When the 
default calibration equations are not suitable for your 
soil type, you can enter your own calibration equations 
here. 
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3. Apply Changes To. After you have made calibration 
changes, specify which parts of your data to apply the 
new calibration to. 

DataTrac Preferences
The Preferences menu allows you to adjust program set-
tings, the way data is displayed on the screen, and select
units you wish DataTrac to use when displaying data. This
menu features four sections, accessed by clicking the tabs
at the top of the screen. Each section and its options are
described here. 

General Program Options 
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• Automatic Internet Version Check. Enabling this
option will have the program check automatically for
updates when the program starts, whenever you are
connected to the Internet. When an update is found,
you will be directed to the website where you can
download it.

• Automatic Clock Synchronization. By default,
DataTrac automatically synchronizes the logger’s
date and time to the time set on the computer. Click
the check box to disable this feature. You can update
the date and time manually anytime you are con-
nected by selecting Actions > Device Tools > Set
Time.

• Date and Time Display in ECH2O DataTrac.
You have control how your logger’s date and time
are displayed on the toolbar. By default, the date and
time are formatted using the settings in the Windows
Regional & Language Options control panel. You
can modify this to display the date and time in day/
month/year format, with either 12- or 24-hour for-
mat. 

• Power Noise Filter (PADC). The AC or “mains”
electrical power we use every day can add a subtle
amount of noise to the logger sensor measurements.
The logger’s Power Noise Filter (PNF) is a setting
designed to eliminate this electrical noise that comes
from the AC power distribution system. You should
set the value of the PNF to match the frequency of
the power cycle where you live. (North America and
most of Asia use 60 Hz, while in most of Europe it is
50 Hz.) This value only needs to be set once.
DataTrac will automatically set the PNF of each log-
ger it connects to.
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Measurement Units Options

• Temperature. Specifies whether temperature read-
out is displayed in Celsius or Fahrenheit.

• Precipitation. Specifies whether precipitation out-
put from the ECH2O Rain Gauge is displayed in
inches or in millimeters.

• Leaf Wetness. Minutes or LWS count. 
• Humidity Specifies whether humidity is displayed in

Water Activity or  % RH.
• Volume. Specifies whether readings from the

ECH2O Rain Gauge are displayed in gallons or liters. 
• Water Potential Axis Drawn. Specifies   whether

the chart axis for readings from the ECH2O Matric
Potential sensor will be drawn highest potential to
lowest, or vice versa.
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• Water Content. Specifies the unit of measurement
for water content readings, as percent volumeteric
water content (% VWC), straight VWC (m3/m3), or
as centimeter per meter (cm/m).

• Drainage. Specifies whether measurements from
the ECH2O Drain Gauge will be displayed in inches,
millimeters or millivolts.

• Water Potential Units. Specifies the unit of mea-
surement for water potential readings, as kPa (kilo-
pascal), Bar, or pF (log scale).

• Electrical Conductivity. You can choose to display
the EC reading in pore water or bulk, as dS/m
(decisiemens per meter), or mmohs/cm (milimoles
per centimeter).

Chart and Data Options
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• Default Plant Available Water Target Zone. Sets a
global target zone of how much water is available in
the measured media. 

• Clipboard Format for Chart.  Sets the image for-
mat when copying the chart.

• Multi-year Data Handling. Allows the user to
retrieve all data from the database or only the current
year data.

Communication Options

• Direct Connect Retries. If you are experiencing
unreliable communication with a logger, set the
number of times the computer will automatically
attempt to reconnect to a logger from 3 to 10 times
(usually, no more than 3 tries should be necessary).

• Radio Connect Retries. If you are experiencing
unreliable communication with a radio logger while
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using a DataStation or Rm1, set the number of times
the computer will automatically attempt to reconnect
to a radio logger from 5 to 12 times.

• Extra Response Time. If you are experiencing
unreliable communication with a device on an Ether-
net connection, increase the Extra Response Time to
match or exceed the delay present in the network.
This causes DataTrac to wait for the data to be avail-
able before trying to read it into the database.

• Maximum Baud Rate for Direct Connection. Set
a baud rate lower than the default 115,200 baud if
you consistently experience a noisy serial connection. 

• Force Find All Serial Ports. If you are using a
model of USB-to-serial adapter that is not recog-
nized in the “Connect Via” menu, enabling this
option will find all available serial ports on your
computer. Your adapter should then be available. (It
may also list some ports that DataTrac cannot use to
connect.)

Click OK to apply any changes made to the Preferences.
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6. Tools
In addition to the many features already discussed,
DataTrac features other tools to interact with your devices
and modify settings controlling downloaded data. 

Printing Reports
DataTrac combines several sources of data to print a
report. The report contains information about the logger,
the chart data (as seen on the screen), the report summary
data, and an optional recommendation text. DataTrac
should support any printer installed in Windows. You may
physically print out a report, or save it as a PDF. 

Print a Physical Report
1. Ensure that your printer is installed and correctly con-

figured by selecting File > Print Setup. Make any 
changes to your printing configuration here. 

NOTE: Paper orientation is ignored; DataTrac will always 
print in portrait format.
 

2. Select File > Print Report.
3. The “Report Comment Page” dialog box appears 

(shown below). Enter any notes or comments here. 
These will appear on the report, but are not saved by 
DataTrac.

4. Click “Print”. 



 ECH2O DataTrac User’s Manual
6. Tools

53

Print a Report as a PDF
1. Follow steps 1 - 3 as outlined above.
2. Click “Save as PDF”. 
3. DataTrac will indicate that a PDF is being generated in

the task bar. After a few seconds, the “Save PDF as”
dialog appears, where you can enter a filename and a
location to save the PDF. Do this, then click “Save”.

4. The PDF will be generated within a few seconds.

Consider choosing data markers on the traces if you plan 
to print the report in black and white (like a laser printer). 
This can better help identify the traces on the chart.

Exporting Chart Data
DataTrac supports exporting the chart data for use in
other applications. You can use the chart data to create
your own custom reports or web pages with third-party
applications (word processors or web authoring software) 

To export a chart:
1. Display the chart to be exported. The exported chart 

image will look exactly as it does on the screen.
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2. Click File > Export > Chart.
3. Name the file and choose file type and location.
4. Save the file.

Notes on Exported Chart File Formats
DataTrac can export the chart data as either bitmap data or
vector data, which can be saved in the following formats:
*.bmp, *.emf, *.jpg, and *.png. Choose Enhanced Metafile
(EMF) vector data if you plan to use the chart in a word
processor or publishing program. The Enhanced Metafile
supports resizing the chart and will give the best looking
text on any printer. The bitmap data formats are useful for
web publishing or for programs that don’t support the
EMF format. The Portable Network Graphics (PNG) for-
mat is a better choice for web publishing than JPEG.

Scan Ports
When you are connected to a logger either directly or via
an Rm1 radio modem, you can take a direct measurement
on all 5 ports by selecting “Scan Ports” from the Actions
menu, or by clicking the “Scan” button on the toolbar.
This allows you to see a real-time measurement for the
ports. These measurements are not saved.
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Redeploy a Logger
At times, you may want to use your logger for a new pur-
pose in a new location. If you simply change the name of
the logger, all of the data stored in DataTrac moves with
the new name as if it were collected with a logger under a
new name. The Redeploy feature allows you to restart a
logger as if it were a new logger with no data. The previ-
ously acquired data will be archived under the old logger
name (or a new name, depending on how the redeploy is
done). 

To redeploy a logger:
1. Connect to the logger.
2. Go to Setup > Redeploy (name of logger).
3. The Redeploy dialog box will appear.
4. You can choose to rename the existing logger, or cre-

ate a new logger while archiving the old data under the
previous name. You can also choose to keep the same
name for the new logger and change the name of the
old logger. Previously acquired data will now be stored
under the new name assigned to the old logger. The
new logger will appear in the device directory under a
specified Farm and Field. You can also choose to erase
all data on the selected logger; be careful - once this
option is selected, all data is deleted and cannot
be recovered! The old logger will still contain all data
previously downloaded. 

5. Once you have assigned these values, click OK. The
new logger will appear where specified, and can be
configured and used to collect data. 
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Exporting a Transfer Set
DataTrac allows you to export the information for a
logger and its data from one copy of DataTrac and import
it into another. DataTrac does this by creating a data file
called a transfer set, which contains all of the data, config-
uration settings, and device directory information for the
selected logger. This file can be especially helpful for trou-
bleshooting ECH2O DataTrac problems. 

To export a transfer set:
1. Select the logger in the device directory that you wish

to export.
2. Go to File > Export > Transfer Set.
3. Specify a file name, and location where the file will be

saved, and then click OK. A transfer set will then be
created and saved to the specified location.

Reading in Saved Data Files
In addition to connecting to a logger and downloading 
data from it, you can also bring saved data (in the form of 
transfer sets) into DataTrac in two ways:

1. Go to C:\Program Files\Decagon\ECH2O DataTrac 
and place the file in the Import directory. 

2. Go to File > Import Data. Find where your transfer 
set is saved (file extension is *.dzd*) and click OK. 

When DataTrac imports the transfer set, it will place the
logger in the same location in the device directory as the
copy of DataTrac that exported it. You do not have to
reconfigure the logger, as all of its settings are automati-
cally applied. When placing a file in the Import directory,
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the data will be automatically loaded into the chart or table
the next time DataTrac is launched.

NOTE: If a logger already exists in your system with the same
name as the one you are attempting to import, DataTrac will
display an error message indicating that you have a naming con-
flict. When this error message appears, you have three options:

• Replace. Replace the current logger with the incom-
ing logger’s calibration, configuration, and data.

• Rename Incoming. Assign the incoming logger a
new name. 

• Rename Existing. Assign the current logger a new
name. This will preserve the logger’s calibration,
configuration, and data. 

When you have made a selection, click “OK” to apply the
changes.

Hiding Unused Sensors
To remove a sensor from the chart view, do the following:

Temporarily:
In the Chart View, click on that sensor’s legend name in
the chart legend. The legend name will display “Off ”. It
will reappear, however, if you click on another logger in
the data tree and come back to the original logger.

Permanently:
1. Go to Setup > Configure > Configuration tab.
2. Under “Chart”, go to Trace Color, select the appropri-

ate line, and select White from the color menu.
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3. Click Apply to make the change permanent. The line
will remain that color until changed again.

Device Tools
The Device Tools menu, located in the Actions main
menu, allows you to perform many tasks, such as erasing
data and changing logger system settings. Each tool is
described below.    

NOTE: This menu is only enabled when you are connected to a
device.

Set Time
(Loggers only) This will set the logger’s date and time to the
current settings on your computer. 

Firmware Test
This will test the logger’s firmware. A dialog box will
appear indicating whether the firmware has tested as
Good or Bad. For more information on firmware and on
obtaining updates, please see the Troubleshooting section.

Telemetry Test
This allows you to verify the radio connection between the
radio logger and the DataStation. Choose "Telemetry
Test" from the Actions Menu.
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Click the Test button and the test will begin. When the test
has finished you will be presented with the results of the
test. You may have to relocate the radio logger while doing
the Telemetry Test in order to find the best connection
quality. Once you have found the radio logger location that
provides the best connection quality, install the radio log-
ger at that location. Disconnect from the radio logger.

NOTE: Telemetry Test only works with Em50 loggers running
firmware 1.12 or newer.

Erase Data in (device name)
To erase data from a connected device, go to “Erase Data
in (device name)”. This will quickly erase all data currently
stored on the device, but will not erase the data already
stored in DataTrac. WARNING! Once this feature is
activated, ALL device data will be erased and cannot
be recovered! 
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Initialize Radio
This feature will reset the radio and all associated settings
(Em50R, Em5R, and DataStation only).  

Initialize (device name)
Occasionally, it may be necessary to reset a logger if you
are continually getting unreliable communications from it.
Click on Initialize Device. This will completely reset the
system, and erase data stored on it. WARNING! Once
this feature is activated, ALL device data will be
erased and cannot be recovered! 
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7. Troubleshooting
Although DataTrac has been designed to run as efficiently
as possible, problems may sometimes occur. The
following chapter details the most common problems you
may encounter and their solutions. Additional information
on DataTrac’s features can be found in the DataTrac help
file. 

PROBLEM: DataTrac informs me the COM port I
am trying to use doesn’t exist.

SOLUTION: This is an operating system issue. Check to
see if the COM port is installed correctly. 

PROBLEM: My USB to Serial adapter is not showing
in the communication port picker. 

SOLUTION: Although DataTrac supports most models
of serial-to-USB adapters, some models might not be rec-
ognized. Do the following:
1. Go to Setup > DataTrac Preferences > “General Pro-

gram Options” tab.
2. Enable the “Force Find All Serial Ports” check box.

This will search the system and find all COM ports;
not all of these, however, can be connected to (i.e.
modem ports). 

3. Return to the “Connect Via” menu. Your adapter
should now be available.

4. If enabling the Force Find check box does not find
your adapter, try one of the following:
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•  Reinstall/update the drivers for your logger;
•  Use another available COM port;
•  Use another model of serial-to-USB adapter.

PROBLEM: DataTrac tells me the communication
port I want to use is busy or in use by another appli-
cation, but I don't think any other programs are run-
ning. 

SOLUTION: Some PDA synchronization software mon-
itors serial communication ports. Disable Microsoft’s
ActiveSync or Palm’s HotSync system software while try-
ing to use the serial port with DataTrac. 

PROBLEM: No data are being displayed, or the let-
ters “NP” appear in the data columns.

SOLUTION: If the error message, “DataTrac did not
load data into the chart” ever appears, one or a combina-
tion of the following may have occurred:
1. The logger or connected sensors are not correctly

configured. When you first configured your logger,
you may not have configured the logger to a Farm or
Field, or not configured what type of sensor is con-
nected to each port. Your logger stores what type of
sensor is connected. You may have selected the wrong
sensor type (i.e. you have connected an EC-20 probe,
but selected an EC-5). Refer to the “Device Setup”
section of Chapter 2.

2. You have deleted all of the data. Once data has
been erased, it cannot be recovered.
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3. The logger does not have any sensors connected.
Check to make sure that the sensors are correctly con-
nected.

4. If there is data present, go to the Preferences menu,
Calibration tab, and enable the “All Data” option, then
click Apply.

PROBLEM: My data shows “ * * * ” in the Scan Ports
window or in the data file.

SOLUTION: The three stars mean the raw data was out
of the expected range for the sensor. This could indicate a
broken sensor. Make sure your sensor type is set correctly
for the type of sensor you have in each port.

PROBLEM: My firmware has become corrupt.

SOLUTION: Firmware - the internal code that makes
the hardware function properly - can occasionally become
corrupt. This may cause your logger to run slower than
usual, or to produce unreliable readings. If your logger is
beginning to show these symptoms, it might be necessary
to test the status of its firmware. Do the following:
1. Go to Setup > Device Tools > Firmware Test.
2. DataTrac will test your logger's firmware, and depend-

ing on its condition, will display a message saying the
firmware check reported the firmware as either good
or bad. If the firmware reports as bad, connect to the
Internet, then go to www.decagon.com/ech2o/
software to obtain a firmware update.

3. If you do not have an Internet connection, cannot
download the update, or problems do not cease after
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installing it, please contact Decagon for instructions
on mailing your logger to us for repair.

PROBLEM: I am receiving unreliable communica-
tion from my logger.

SOLUTION: It may be necessary to reset your logger if
you are continually getting unreliable communication
from it. Do the following:
1. Open the logger case.
2. At the top of the circuit board there is a small silver

button with the word RESET above it. Press this
once. When you do this, the green status light will
come on for a few seconds, then continue to blink
periodically.

3. This will reset the processor. You will not lose any of
your stored data or settings when you initiate a reset.

PROBLEM: DataTrac informs me there is no radio
in the logger when I try to communicate via an Rm1
to that logger.

SOLUTION: In this case DataTrac needs to acquire the
logger’s radio settings. This can be done in two ways; by:
1. Directly connecting to the radio logger and retrieving 

all of its settings; or
2. Initiating a “Query Any” and attempting to connect to 

that logger. If the logger answers a “Query Any,” then 
DataTrac will update the settings for that logger.

PROBLEM: My Rm1 is not connecting to radio
loggers. 
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SOLUTION: There are a myriad of error messages
which could cause such a problem. 

If “No Rm1 detected” or “Cannot setup Rm1” type error message
appears: 

• Make sure the Rm1’s power supply is connected and
that the Rm1 is turned on.

• Reset the Rm1 by pressing the “Reset” switch on the
case.

• Check that the Rm1 is connected to the correct
COM port or serial-to-USB adapter.

If there is no reply from a logger:
• Make sure the radio antenna is connected. 
• Check that it has been 10 minutes since you last

attempted to communicate via the Rm1. 
• Verify that the logger in DataTrac’s configuration

(channel, sub channel, and radio mode) are the same
as the radio logger you are trying to reach. 

• Any radio interference can disrupt the Rm1’s signal
and cause it to take longer to reach a radio logger, or
not reach it at all. Make sure the Rm1 and radio log-
ger have not been setup by metal buildings, or by
anything that could interfere with the transmission. 

• If there is a reply from a logger, and a message
appears indicating a problem with the logger, this
does not apply to DataTrac. See that logger’s opera-
tor’s manual for a solution.

PROBLEM: My radio logger or Rm1 is taking too
long to connect to a remote logger.
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SOLUTION: If your radio logger does not connect to
your Rm1 transmitter after 50 seconds:
1. Make sure that the logger is still transmitting. As soon

as you disconnect from a logger, the radio becomes
inactive for 10 minutes. You can fix this by waiting 10
minutes, or by doing a complete system reset.

2. Make sure the radio logger is set to a radio mode
other than “Radio Off/No Radio” or “Unknown
Radio Mode”. This can be changed by going to
Setup > Configure > Configuration tab > Radio.
Mode #0 is Radio off/No Radio; mode #4 is Trans-
mit & Communicate 24 hrs. See Chapter 2 for a
description of the radio modes.

PROBLEM: How do I know if my connected sensors
are working properly?

SOLUTION: Once you have connected and configured
your logger, you may want to check to see if your sensors
are working properly. This can be done by doing the fol-
lowing:
1. Go to Actions > Scan Ports.
2. DataTrac will do an immediate scan of all the ports

and display the data for each sensor. 
3. Each port also has the option of displaying unproc-

essed data. Selecting this will display that port’s
unprocessed value.

4. To take another reading, click “Scan Again”. If this
proves successful after several attempts, the sensors
are configured and working correctly.

PROBLEM: The error message “DataTrac cannot
set any global settings” appears.
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SOLUTION: The best solution to this message is to
completely reinstall DataTrac. Doing this will erase all data
and settings currently stored in your current version of
DataTrac. Please contact your ECH2O System sales repre-
sentative for help with this problem. 

PROBLEM: The error message “Cannot get device
settings” appears when I connect to my logger.

SOLUTION: Try connecting to the logger again. If this
does not work, reset your logger, disconnect, and try to
connect again, or close DataTrac and reboot your com-
puter. If the problem still persists, contact your ECH2O
System sales representative.

PROBLEM: I receive an error message when trying
to rename my logger.

SOLUTION: When you name or rename a logger, it
must conform to the following standards:

•  No more than 8 characters;
•  No punctuation (“ ” , ? : etc.);
•  No whitespace characters;
•  You must rename the logger you are connected to;
•  You cannot rename a logger unless you are

connected to it;
•  The new logger name must be unique from other

loggers in the system;

PROBLEM: The message “Cannot build Device
Tree” appears when I start DataTrac.
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SOLUTION: When this occurs, something may have
gone wrong with DataTrac’s database engine files.
DataTrac’s database files are contained inside the
EchoWorkingFiles directory. This is found at C:\Program
Files\Decagon\ECH2O DataTrac. (This is a hidden
directory, so you will need to enable viewing hidden files
to access it.) Do the following:
1. Check how many files the folder contains. The folder

must contain a minimum of 32 files for DataTrac to
function correctly. 

2. Verify that DataTrac has write permissions to write
files to this directory. 

3. Verify that the Borland Database Engine (BDE) is
installed and functioning correctly. To test this, go to
Start > Programs > BDE Information Utility. This
will open a diagnostic window. Click the “Test BDE”
button. This will perform a diagnostic test of the
BDE. If all is well, the program will display “The BDE
is installed and working properly”. 

4. If the problem still persists, you may have to com-
pletely reinstall DataTrac.

NOTE: It is best to restart DataTrac entirely after performing a
repair.

PROBLEM: When I try to license DataTrac, the pro-
gram will not accept my license key.

SOLUTION: Only DataTrac version 2.60 or newer sup-
ports licensing. Make sure to do the following:

•  When you enter your license key, you must enter
your name, company name, and license key exactly as
they appear on the license sheet. 
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NOTE: To avoid confusion between the number zero and the
letter “O”, the license key will only contain “O”s.
 

•  When you enter the license key, it must be entered in
groups of four as shown on the license sheet. 

•  Make sure that the key you received is for the proper
version of DataTrac (it will say on the license key
sheet). 

PROBLEM: My 30-day evaluation period has expired
and I need more time. 

SOLUTION: You may obtain a 30-day extension of your
evaluation period by contacting your sales representative. 

PROBLEM: I select a data point in the Table View,
but when I return to the Chart View I cannot find my
data.

SOLUTION: This problem has multiple solutions. First,
under the Chart View menu, select a different view than
what is selected. This will readjust the chart and may
adjust the axes such that your data are displayed. If this
does not work, you can also click on the axes and drag
them in the appropriate direction to manually resize them
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Appendix A

Send Feedback to Decagon

Decagon Software makes it easy to send feedback, bug
reports, and feature requests to Decagon or your Decagon
Distributor. Choose “Send Feedback to Decagon...” from
the help menu. This opens the window shown below.

Enter your name, company name, and other contact infor-
mation. Tell us what type of feedback you are sending
(General Feedback, Feature Suggestions, Bug Report, or
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Other). Indicate how you want us to respond to your feed-
back (Email or Telephone).

Use the description area to give details for your feedback.
If you are reporting a bug, it is very helpful for you to tell
us what steps you took for the bug to happen and any
error message you saw. By default, bug reports also
include the software error files.

You can send Decagon a file using this form too. This is
useful for sending data files that you have questions about.

If you work directly with a Decagon representative, put
their E-mail address in the field at the bottom of the form.
This sends the contents of the form to them. Your Deca-
gon representative can follow-up with you directly.



 ECH2O DataTrac User’s Manual
Appendix A

72



ECH2O DataTrac User’s Manual
Index

73

Index

A
Appendix A 70

C
Chart view 34
Charting data

adjusting the chart axis 41
options 40

Copy chart 7
Create new 8
Customer Support 1

D
DataStation

configuring 20
connecting to a 20
description 19

DataTrac Preferences
Chart View Options tab 48
Communication Options tab 50
General Program Options tab 46

DataTrac Preferneces
Season and Target Zone tab 49

Device description area 14
Device directory

description 13
setting up 15

Device Setup
Calibration tab 45
Configuration tab 28, 42
Logger tab 27



ECH2O DataTrac User’s Manual
Index

74

Device status area 12
Device tools

erase data in 59
firmware test 58
set time 58

E
Editing data points 39
Export

table 6
Exported chart file formats 54
Exporting chart data 53

F
Farm

creating 15
Field

creating 17

H
Hiding unused sensors

permanently 57
temporarily 57

I
Import file data 6
Initialize device 60
Initialize radio 60
Installating DataTrac

from CD 3
from the web 3



ECH2O DataTrac User’s Manual
Index

75

L
Licensing 3
Logger

connecting to
via Rm1 radio modem 24
via SCA (serial cable adapter) 22
via UCA (USB adapter) 22

M
Menu bar

Actions 9
Edit 7
File 6
Help 11
Setup 8

P
Print

print setup 7

R
Radio modes 30
Reading in saved data files 56
Redeploy logger 55
Reload data for 8

S
Scan ports 54
Season view 35
System requirements 1

T
Table view 37



ECH2O DataTrac User’s Manual
Index

76

Taskbar 14
Ttoolbar, using 12
Transfer set

description 56
exporting 56

W
Warranty 2

Z
Zoom 8


